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Numeryczne modele wysokościowe 
 

Od połowy 2020 r. Główny Urząd Geodezji i Kartografii (GUGiK) umożliwia bezpłatny i otwarty dostęp 

do usługi pobierania arkuszy Numerycznego Modelu Terenu (NMT) i Numerycznego Modelu Pokrycia 

Terenu (NMPT) znajdujących się w Państwowym Zasobie Geodezyjnym i Kartograficznym. 

W Poradniku znajduje się charakterystyka udostępnionych danych wysokościowych, metody 

ich pobierania, wstępnego przygotowania przed dalszą analizą i przykładowe produkty wytworzone 

na bazie NMT i NMPT.  

Wykorzystane oprogramowanie to QGIS 3.16.4 i SAGA GIS 2.3.2.  
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Charakterystyka danych  

Numeryczny Model Terenu przechowuje wartości wysokości powierzchni terenu nad poziom morza. 

Natomiast Numeryczny Model Pokrycia Terenu reprezentuje zarówno rzeźbę odkrytego terenu jak 

i wysokość obiektów, które się na nim znajdują takich jak: roślinność, budynki, elementy infrastruktury. 

Rozdzielczość przestrzenna zależy od rodzaju (NMT czy NMPT) oraz lokalizacji produktu (średnie i duże 

miasta czy inne obszaru) i wynosi 1 m (NMT, NMPT) lub 0,5 m (NMPT), a średni błąd wysokości wynosi 

między 0,1 a 0,2 m.  

Dla niektórych obszarów Polski można pobrać NMT z rozdzielczością 5 m i średnim błędem wysokości 

0,5 m. Taki model zwykle wystarcza do ogólnej analizy ukształtowania terenu przy opracowywaniu 

większych obszarów (map w bardziej przeglądowych skalach). Do szczegółowej analizy warto stosować 

NMT z rozdzielczością 1 m.  

Dane dostępne są w dwóch układach wysokościowych: 

• PL- KRON86-NH - starszy (obowiązujący do 2019 r. włącznie) 

• PL-EVRF2007-NH – aktualnie obowiązujący w Polsce (od 2020 r.) 

Układy różnią się punktem 0. Wartości wysokości nad poziom morza nieznacznie różnią się pomiędzy 

układami. Należy uważać przy łączeniu danych NMT i NMPT wytworzonych w różnych układach!! 

Na Geoportalu Krajowym dane można pobrać w dwóch formatach: 

• ARC/INFO ASCII GRID – plik tekstowy z rozszerzeniem .asc, składa się z nagłówka opisującego 

właściwości rastra (rozmiar piksela, liczbę kolumn i wierszy, współrzędne XY początku układu 

rastra) oraz wykazu współrzędnych wysokości zapisanych wiersz po wierszu, 

• ASCII XYZ GRID – plik tekstowy .txt; w kolejnych wierszach pliku zapisane są współrzędne X, Y, 

Z dla poszczególnych punktów siatki grid. 

Plik w formacie .txt zajmuje więcej miejsca na dysku niż plik w formacie .asc.   

Dane są dostępne w cięciu arkuszowym w skali 1:5 000 w układzie współrzędnych PUWG 1992 (EPSG 

2180). Poniżej przykład arkusza M-34-39-D-d-4-1.   
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Pobieranie NMT / NMPT z Geoportalu Krajowego  

W 2020 r. GUGiK zaczął udostępniać do pobrania kilka zbiorów danych, m.in. NMT i NMPT na stronie 

Geoportalu Krajowego pod adresem www.geoportal.gov.pl.  

Aby dane ściągnąć na własny dysk, należy włączyć odpowiednią warstwę w podziale arkuszowym 

znajdując ją po prawej stronie mapy w menu Zawartość mapy w Danych do pobrania. W oknie mapy 

pojawi się siatka arkuszy. Po kliknięciu na jeden z nich i wybraniu odpowiedniej warstwy (w poniższym 

przykładzie jest to NMT) pojawi się okno z linkiem do pobrania pliku oraz podstawowymi informacjami 

opisującymi dany arkusz zawierającymi m.in. jego godło, rozdzielczość przestrzenną modelu, datę 

pozyskania danych i ich format.  

 

 

 

W podobny sposób można pobrać NMPT.  
  

http://www.geoportal.gov.pl/
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Pobieranie NMT przez usługę WCS 

Wczytanie NMT lub NMPT za pomocą usługi WCS1 w QGIS pozwala na pobranie dowolnego obszaru 

znajdującego się w granicach Polski. Nie ma potrzeby ściągać i łączyć arkuszy zapisanych w oddzielnych 

plikach. Od niedawna można korzystać w ten sposób z NMT, NMPT i ortofotomapy, które znajdują się 

w zasobach GUGiK. 

Dostępne są różne adresy usługi WCS (https://www.geoportal.gov.pl/uslugi/usluga-sieciowa-wcs) 

w zależności od formatu danych: 

• ArcInfo ASCII Grid (oba układy wysokościowe) – dla NMT i NMPT, 

• GeoTIFF (tylko w starym układzie PL- KRON86-NH) – dla NMT. 

Należy pamiętać, że dane udostępniane poprzez usługę WCS mają dużą rozdzielczość przestrzenną, 

toteż czas ich pobierania może być długi. 

W przeciwieństwie do pobierania danych na Geoportalu Krajowym, ten sposób ściągania modeli 

wysokościowych nie pozwala na uprzednie zapoznanie się z ich rozdzielczością przestrzenną czy datą 

pozyskania danych. 

 

1. Otwórz Warstwa » Dodaj warstwę » Dodaj warstwę WCS.  
 

2. Aby ustanowić nowe połączenie WCS kliknij na przycisk Nowy. Wpisz nazwę podłączanej warstwy 

i skopiuj adres URL usługi ze strony Geoportalu Krajowego (powyższy link). Kliknij OK. W ten sposób 

adres zostanie zapamiętany przez program i będzie dostępny na rozwijanej liście. 
 

3. Teraz kliknij Połącz. Poniżej powinna pojawić się lista warstw. Warstwa może być jedna lub będzie 

ich więcej, w zależności od rodzaju podłączonych danych przestrzennych. Zaznacz wybraną 

warstwę i kliknij Dodaj. Gdy dane pojawią się na liście warstw mapy możesz kliknąć Zamknij. 

                                                           
1 WCS – Web Coverage Service, usługa pobierania danych przestrzennych zapisanych w modelu rastrowym.   

https://www.geoportal.gov.pl/uslugi/usluga-sieciowa-wcs
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4. Aby pobrać dane, wystarczy kliknąć prawym 

przyciskiem na nazwę warstwy i wybrać 

Eksportuj » Zapisz jako… . W oknie, które się 

pojawi, należy: 

• wybrać format danych - najczęściej 

będzie to GeoTIFF,  

• nadać nazwę pliku i miejsce zapisu 

na dysku,  

• wybrać układ współrzędnych, 

• wybrać zasięg z następujących opcji:  

- zasięg bieżącej warstwy - często 

jest to cała Polska, a więc ogrom 

danych, dlatego najlepiej pominąć 

tą możliwość,  

- wylicz z warstwy - gdy posiadamy 

własny zasięg w pliku shapefile lub 

innym, określający granice terenu, 

który chcemy pobrać,  

- zasięg widoku mapy, 

• wpisać poprawną wielkość piksela 

(rozdzielczość) – zwykle będzie to 1 m, 

• zaznaczyć bądź odznaczyć opcję powodującą dodanie zapisanego pliku do mapy. 

Na koniec kliknąć OK. Dane zostaną zapisane do pliku. Postęp tego procesu można śledzić 

na dolnym pasku okna programu.     
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Pobieranie danych przez wtyczkę QGIS „Pobieracz Danych GUGiK” 

Wtyczka została przygotowana przez firmę EnviroSolutions i umożliwia pobieranie otwartych danych 

przestrzennych udostępnianych przez GUGiK, m.in. NMT i NMPT.  

 

1. Po zainstalowaniu wtyczki można ją znaleźć 

w zakładce Wtyczki » EnviroSolutions » 

Pobieracz Danych GUGiK. 
 

2. Na początku należy określić miejsce, gdzie pliki 

zostaną zapisane.  
 

3. Po wyborze rodzaju danych przestrzennych, 

należy wybrać format danych (.asc lub .txt) oraz 

układ współrzędnych wysokościowych. 
 

4. Określenie obszaru zainteresowania odbywa się 

poprzez wskazanie punktu na mapie lub 

wybranie warstwy wektorowej z własnym 

zasięgiem.  
 

5. Dane można przefiltrować ze względu układ 

współrzędnych płaskich, datę wykonania 

i rozdzielczość. 
 

6. Po wybraniu Pobierz warstwę wektorową 

wyświetli się komunikat mówiący o tym ile 

plików zostało znalezione. Należy zatwierdzić 

chęć ich pobrania.  
 

7. Oprócz plików zawierających dane przestrzenne, 

w docelowym folderze znajdziemy również plik 

tekstowy .csv zawierający metadane odnośnie 

pobranych plików. Plik ten można wczytać poprzez Warstwa » Dodaj warstwę » Dodaj warstwę 

tekstową CSV… i wybranie następujących parametrów: 

• Format pliku – CSV (rozdzielone przecinkami), 

• Opcje wierszy i kolumn – zostawić domyślne, 

• Ustawienia geometrii – bez geometrii (tylko tabela atrybutów). 
 

Po kliknięciu Dodaj warstwa pojawi się w menu Warstwy. Po otworzeniu tabeli atrybutów można 

znaleźć opis danych, które zostały pobrane.    
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Łączenie arkuszy w jeden plik 

Poniższe działanie należy wykonać w przypadku pobrania NMT / NMPT w postaci arkuszy lub 

mniejszych fragmentów terenu. Zwykle ściąga się kilka-kilkadziesiąt arkuszy, żeby pokryć obszar 

zainteresowania. Aby móc wytworzyć pochodne produkty z NMT (lub NMPT) należy połączyć pliki 

w jeden za pomocą narzędzia mozaikowanie. Najwygodniej jest użyć programu SAGA GIS, który 

wchodzi w skład pakietu ściąganego wraz z QGIS.  

Wczytanie plików do programu SAGA GIS odbywa się albo 

poprzez przeniesienie plików do okna mapy albo wybierając 

w menu File » Grid » Load. Rozszerzenie plików należy zmienić 

na All Files, a następnie zaznaczyć wszystkie lub wybrane 

pliki .asc. 

Aby zmozaikować wczytane pliki należy wybrać z menu 

Geoprocessing » Grid » Grid System » Mosaicking. Dodać 

warstwy do Input Grid poprzez ich zaznaczenie i przeniesienie do 

prawego okienka. Kliknąć OK.  

W kolejnym oknie należy sprawdzić czy Cell size (rozmiar piksela) 

jest poprawny – zwykle dla danych GUGiK będzie to 1 m. 

 

Rozmiar wyjściowego piksela może być taki sam jak w wejściowych plikach, ale można też go zwiększyć 

– wtedy szczególnie ważny jest parametr określający metodę resamplingu. Poprzez zwiększenie Cell 

size można zmniejszyć rozmiar wyjściowego pliku kosztem szczegółowości rzeźby terenu. 
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Zapis do pliku (np. GeoTIFF, ale wybór formatów jest większy) odbywa się poprzez wybór z menu 

Geoprocessing » File » Grid » Export » Export GeoTIFF. Parametry do ustawienia: 

• Grid System – należy wybrać nowopowstałą warstwę mozaiki (najłatwiej rozpoznać ją 

po większych liczbach piksel x piksel niż w pozostałych warstwach). 

• Po kliknięciu na Grid(s) należy przenieść warstwę do okna na prawo i kliknąć OK. 

• File – trzeba wybrać miejsce zapisu i wpisać nazwę pliku wraz z rozszerzeniem, 

np. „nmt_1m.tif”. 

Po kliknięciu OK w głównym oknie, plik zapisuje się w wybranym katalogu.  

 

W tym miejscu można zakończyć pracę w programie SAGA GIS. Pozostałe czynności zostaną omówione 

na podstawie pracy w programie QGIS. 
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Wizualizacja NMT / NMPT 

Po wczytaniu rastra z NMT czy NMPT do programu QGIS zwykle otwiera się on w postaci czarno-białego 

obrazu. Sposób wyświetlania NMT / NMPT można zmienić we właściwościach warstwy (Style). 

Do wyboru są: jednokanałowy szary (domyślny), jednokanałowy pseudokolor, cieniowanie i warstwice 

(poziomice). 

Aby wyświetlić dane w skali barwnej należy: 

• Zmienić Sposób wyświetlania na Jednokanałowy pseudokolor. 

• Ustawienia wartości minimalnej i maksymalnej ustawić na min/max. 

• wybrać Paletę kolorów. Najczęściej będą to barwy od zielonej, przez żółtą po czerwoną. 

Kliknięcie prawym przyciskiem na pasek z paletą powoduje wyświetlenie menu 

kontekstowego, w którym można odwrócić kolejność kolorów, edytować paletę lub stworzyć 

własną paletę kolorów. 

• Zastosowanie interpolacji liniowej powoduje rozmycie granic między poszczególnymi 

kolorami. Wybór interpolacji dyskretnej spowoduje, że poszczególne zakresy wysokości terenu 

będą wyraźnie oddzielone kolorami.  

• Tryb klasyfikacji i ilość klas pomaga określić przedziały wartości. Wybór trybu zależy od tego 

jaki efekt chce się osiągnąć, jakie jest zróżnicowanie terenu. Np. kwantyl warto wybrać, gdy 

obszar zainteresowania zawiera zarówno stosunkowo duży teren o niewielkim zróżnicowaniu 

wysokości tj. równinna dolina rzeki jak i przykładowo fragment wysoczyzny ze skarpą. Wtedy 

nie „zginie” zróżnicowanie wysokościowe równiny. Podobnie w przypadku prezentacji NMPT 

z budynkami i roślinnością. Zakres wartości klas można też ustawić ręcznie. 

  
Ryc. 2. NMPT - klasyfikacja z trybem równe przedziały. 
Zakład przemysłowy w Kwidzyniu. 

Ryc. 1. NMPT - klasyfikacja z trybem kwantyl. 
Zakład przemysłowy w Kwidzyniu. 
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Sposób wyświetlania można też ustawić na Cieniowanie. Współczynnik Z służy do sterowania 

przewyższeniem terenu, czyli jego stopniem „wypukłości”. Domyślnie jest ustawiony na 1.0. Azymut, 

z którego pada oświetlenie, zwykle ustawia się na 315°, a wysokość „słońca” na 45°. 

 

 

Poziomice generują się po wybraniu Warstwice jako sposób wyświetlania. Należy określić cięcie 

poziomicowe: 

• pomocnicze (Contour Interval) – np. 5 m, 

• główne (Index Contour Interval) – np. 25 m 

oraz współczynnik generalizacji linii (Input Downscalling) – np. 4,0.  

Niestety ten szybki sposób generowania poziomic nie pozwala na wyświetlenie etykiet poziomic 

informujących o wysokości n.p.m. Aby to zrobić, należy stworzyć osobną warstwę wektorową 

z poziomicami – opis poniżej.  

 

 

Aby sprawdzić wysokość danego punktu na mapie, wystarczy włączyć narzędzie  Informacje 

o obiekcie znajdujące się na pasku narzędziowym lub w zakładce Widok. Kursor zmienia swój wygląd 

na czarną strzałkę z literą i.  

Po kliknięciu na wybrane miejsce pojawia się nowe 

okno po prawej stronie mapy, w którym znajduje 

się wartość wysokości w metrach.  

 

 

 

  

Ryc. 4. NMT, cieniowanie, współczynnik Z = 3,0. Ryc. 3. NMT, cieniowanie, współczynnik Z = 1,0. 



 

NMT i NMPT  11 

Poziomice 

Poziomice można również stworzyć za pomocą narzędzi do przetwarzania rastrów.  

Należy wybrać z paska menu Raster » Cięcie » Warstwice. Wybrać warstwę rastra z NMT, określić cięcie 

warstwicowe. Nazwa atrybutu wysokości (który zostanie stworzony w tabeli atrybutów nowopowstałej 

warstwy) jest domyślnie wpisana jako ELEV. Nowo powstały plik SHP można zapisać na dysku lub 

stworzyć tylko warstwę tymczasową. Po kliknięciu Uruchom powstaje nowa warstwa wektorowa, 

której linie są opisane atrybutem wysokości. Tą kolumnę w tabeli atrybutów, można wykorzystać do 

stworzenia etykiet. 

Zazwyczaj potrzeba również delikatnie zgeneralizować poziomice, aby pozbyć się m.in. ostrych 

załamań w przebiegu linii. Służy do tego wtyczka Cartographic Line Generalization. Za jej pomocą 

można usunąć małe obszary (remove too small areas), wybrać wyjściową skalę (map scale 

denominator, np. 1:5 000) oraz rodzaj generalizacji:  smoothing (wygładzanie). Im zostanie wybrana 

mniejsza skala, tym zastosowana zostanie większa generalizacja przebiegu warstwic.  

 

 

Aby rozróżnić linie oznaczające poziomice główne 

i pomocnicze, należy w stylizacji warstwy wybrać: wartość 

unikalna. Sklasyfikować po wartości ELEV. Połączyć 

wartości główne (np. 25, 50, 75, 100) oraz pozostałe 

wartości (np. 15, 20, 30, 35, 40, itd.). Wybrać styl obu linii. 

Przy tworzeniu mapy A3 w skali 1:30 000 linie warstwic 

muszą mieć min. 0,3 mm, aby było je widać na mapie 

w formacie JPG. 
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Chcąc wyświetlić wartości wysokości jako opis 

poziomic należy włączyć Etykiety poziomic i wybrać 

Proste etykiety, wartość ustawić na ELEV, wybrać 

rodzaj czcionki i jej rozmiar, krycie (można zmniejszyć 

do 90%). Aby etykiety były widoczne na tle linii 

poziomicy należy włączyć otoczkę (rozmiar ok. 0,7, 

kolor biały, krycie ok. 40%). W zakładce 

Rozmieszczenie należy wybrać położenie: elastycznie, 

na linii. Priorytet wyświetlania zwykle domyślnie jest 

ustawiony na średni, ale jeśli wyświetla się 

niepotrzebnie dużo etykiet, można spróbować 

posterować tym parametrem i go zmniejszyć. Można 

też włączyć parametr Unikaj etykiet zakrywających 

obiekty.   
Ryc. 5. NMT z cieniowaniem, poziomicami i etykietami. 
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Cieniowanie 

Cieniowanie, podobnie jak poziomice, można uzyskać na dwa sposoby: 

• włączyć odpowiedni sposób wyświetlania w Stylach warstwy, 

• wygenerować za pomocą narzędzi do przetwarzania rastrów. 

Odpowiednie narzędzie znajduje się w górnym pasku menu w zakładce Raster » Analiza » Cieniowanie. 

Podstawowe parametry do ustawienia to: współczynnik Z służący do sterowania przewyższeniem 

terenu, czyli jego stopniem „wypukłości” (domyślnie jest ustawiony na 1.0), azymut światła, czyli 

kierunek z którego pada oświetlenie (zwykle ustawia się na 315°) oraz wysokość światła nad 

horyzontem na 45°.  

Dostępne są też dodatkowe opcje, takich jak: cieniowanie złożone (combined shading) lub 

wielokierunkowe cieniowanie (multidirectional shading). Efekt końcowy różnych kombinacji można 

prześledzić na poniższej rycinie. 
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Spadki 

Mapę spadków można uzyskać stosując funkcję 

analizy nachylenia znajdującą się w górnym pasku 

menu w zakładce Raster » Analiza » Nachylenie… . 

Narzędzie pozwala na zamianę jednostki nachylenia 

z stopni na procenty. Pozostałe parametry można 

zostawić bez zmian. Wynik można zapisać od razu do 

pliku lub kliknąć Uruchom, dzięki czemu powstanie 

nowa warstwa rastrowa w formie tymczasowego 

pliku.  

W stylach nowopowstałej warstwy należy zmienić 

skalę barwną na: 

• sposób wyświetlania: Jednokanałowy 

pseudokolor, 

• ustawienia wartości minimalnej i maksymalnej ustalić na min/max, 

• paleta kolorów: np. Reds, 

a następnie dostosować przedziały wartości klas nachylenia terenu. 

Aby zachować analizę (jeśli wcześniej wybrano plik tymczasowy), należy warstwę Nachylenie 

wyeksportować do pliku GeoTIFF. 
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Ekspozycja 

Podobnie można stworzyć mapę ekspozycji czyli określić 

azymut stoków. W górnym pasku menu należy wybrać 

zakładkę Raster » Analiza » Ekspozycja… .  

Parametry można pozostawić bez zmian i od razu zapisać 

wynik na dysku lub kliknąć Uruchom, dzięki czemu powstanie 

nowa warstwa rastrowa w formie tymczasowego pliku, który 

należy później zapisać. 

Wynikowy raster przyjmuje wartości od 0 do 360 stopni. 

W Stylach warstwy należy zmienić skalę barwną i ustalić 

odpowiednie przedziały wartości dla 4 (przykład klasyfikacji po 

prawej i mapa poniżej) albo 8 kierunków świata. 

 

  

Ryc. 6. Z lewej: cieniowany NMT, z prawej: mapa ekspozycji. 
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Profil terenu 

Profil terenu można wygenerować za pomocą wtyczki Profile Tool. Po włączeniu narzędzia należy 

narysować linię profilu klikając na mapie. Podwójne kliknięcie kończy rysowanie. Następnie 

po kliknięciu Add Layer (warstwa NMT / NMPT powinna być podświetlona na liście warstw) wyświetla 

się wykres profilu terenu. Podane są minimalna i maksymalna wysokość. Wykres jest połączony 

z mapą, więc można prześledzić wysokości za pomocą kursora. Profil można zapisać w pliku PNG, SVG 

lub DXF.  
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Znormalizowany numeryczny model pokrycia terenu 

Wysokość względną obiektów takich jak budynki, roślinność czy elementy infrastruktury można 

uzyskać poprzez odjęcie NMT od NMPT.  

Ważne!  Oba modele (NMT i NMPT) muszą mieć ten sam układ wysokościowy.  

 

1. Wczytaj do QGIS rastry z NMT i NMPT.  

 

2. W górnym pasku menu wejdź w Raster znajdź narzędzie Kalkulator rastra. Wpisz wyrażenie, 

w którym odejmiesz wartości zawarte w pikselach NMT od wartości NMPT (NMPT -  NMT). Wybierz 

nazwę nowej warstwy i miejsce jej zapisu oraz wskaż układ współrzędnych (np. EPSG 2180). 

Kliknij OK.  

 

 
 

 

3. Po chwili uzyskasz cyfrowy model określający wysokość obiektów względem poziomu terenu.  

 


